User Manual

Release – 2.0.0 (Description)

Updated on

Release Date: 08/19/2026

This article provides a detailed description about the

  • new features in version 2.0.0,
  • improvements that have been implemented.

For an overview of the new features, refer to the article Release Notes 2.0.0 (Major Release).

1. New Features

Section provides a detailed description of new features that have been implemented in the Impose Editor, Automation, user interface, API, and Data Validation and Data Preparation.

1.1. Impose Editor

In version 2.0.0, existing features of the Impose Editor were expanded and optimized. The following new features and improvements were implemented:

1.1.1. General New Features and Improvements

Two improvements were implemented in the behavior of the Impose Editor. First, behavior when rotating Print Items while using Pre-Angulation was revised. As a second step, compliance with the Minimum Sheet Height for Roll Substrate was improved.

Using Pre-Angulation

Rotation of Print Items in Impositions using Pre-Angulation has been made consistent. Previously, certain combinations with Pre-Angulation values and Print Item size could cause the Print Item to rotate unexpectedly on the Artboard. It happened, e.g., that the Print Item was rotated 180° instead of 0° or 270° instead of 90°. As of version 2.0.0, Pre-Angulation is always calculated from the Print Item's center point, so the resulting rotation is predictable and reproducible, regardless of the Print Item's original orientation.

Minimum Sheet Height for Roll Substrate

As of this version, the Minimum Impose Height [1] for roll substrates is only exceeded in cases where it's genuinely unavoidable. Previously, the minimum impose height could end up being exceeded whenever a Print Item could only be placed on the imposition by rotating the Print Item. In that case, the height of the un-rotated Print Item was used as the minimum Impose height, which then allowed squeezing in extra Print Items.

For roll media, the minimum imposition height is now only exceeded automatically in these cases:

  • The Print Item is wider than the substrate width, so it has to be rotated to be placed on the imposition.
  • The Print Item is wider than the minimum impose height, so it has to be placed rotated by 90° (see the figure below).
  • The Print Item is longer than the minimum impose height, so it has to be placed with 0° rotation.

Figure 1: Imposition with an imposed Print Item on a roll substrate that is wider than the minimum substrate height

1.1.2. Dynamically Derive Color Values for Captions

Starting with this version, it is possible to dynamically derive the color value for the background color of a text caption from a source, i.e., a user-defined field.

To do this, you have to:

  • Create a custom field – text input or drop-down list – for the Print Item or an Order.
  • Specify the color name or color code for the Print Item or Order.
  • Create a text caption in the imposition, e.g., for the Print Item.
  • Select the color option Derive from User-defined Field [3] with the Background Color enabled [2].
  • Select the user-defined field [4] – e.g. Color Code – containing the color code from the drop-down menu.
  • Select the Fill option under Create background as [5].

Figure 2: Left: The Color Options panel with the Background Color of a text caption enabled in the Marks tab; Right: The Edit Order dialog with a user-defined field – Color Code – and its corresponding value

The color value can be defined in the user-defined field using the following color formats:

  • CMYKBy entering the color value cmyk(0,0,0,1)
  • RGBBy entering the color value rgb(1,0,0) or rgb255(255,0,0)
  • LabBy entering the color value lab(50,25,-30)
  • Registration Mark ColorBy entering the color value all
  • Named Colors (CSS) By entering the color name (see the corresponding overview for a list of available color names)
  • HEX values (CSS)By entering the value #FF5733
  • No colorBy entering none

Purpose

Use this feature to color-code Print Items that, for example, belong to the same order. In final production, color-coding can help reduce errors when individual Print Items from a nesting have to be grouped by order.

 

1.1.3. Color Control Stripe – Advanced Text Options

Expanded text options were added for the Color Control Stripes – Spot Colors and Color Control Stripes – Process Colors features — these include the following options:

  • Display Tint Values [6] – Select this option to display the tint values for the Color Control Stripe.
  • Offset – Tint Values [7] – Use this to specify the offset from the Mark for the displayed tint values.
  • Display Color Names [8] – Select this option to display the color names for the Color Control Stripes.
  • Offset – Color Names [9] – Use this to specify the offset from the Mark for the displayed color names.

Figure 3: Marks tab, featuring the Color Control Stripes – Spot Colors and the advanced text options

1.1.4. "Fotoba" Cutter – Background Color

User is now enabled to define a background color for Fotoba marks. To do this, go to Color Settings, enable the Background Color option [10], and select the desired CMYK values or desired spot color.

Figure 4: Finishing tab with the selected Fotoba cutter device

1.1.5. Impose Mode »Bound Product« – Restrictions

In this version, two changes have been made to the impose mode Bound Product:

  • Only one Print Item can be used. When attempting to add another Print Item, a notification will appear.
  • In the user interface, in the “Print Items” tab, icons that can no longer be used have been removed. Only the Delete icon [11] remains available.

Figure 5: Left: The message that appears when attempting to add another Print Item; Right: Print Items tab with the Delete icon

1.2. Check-in Preflight and Fixup Templates

Following new features were implemented in the Check-in Preflight and Fixup Templates:

1.2.1. Prepare Technical Spot Colors – Handling of Technical Spot Colors with a tint value of 0 %, set to Knockout (White Objects)

In version 2.0.0, two enhancements were implemented for the Fixup "Prepare Technical Spot Colors" which was originaly introduced in version 1.22.2:

  • User can configure for technical spot colors with a tint value of 0% whether the spot colors should be processed as "White" (and thus set to Knockout) or as overprinting (and thus not visible in the printed result) [12].
  • When the Technical Color was created as a solid area in the Print Item, an error message is displayed by default.

Figure 6: Fixup Prepare Spot Colors, using the function Handling of Technical Spot Colors with a tint of 0% , set to Knockout (White Objects)

1.2.2. New Checks

New checks are available in all Check-in Preflight and Fixup Templates. However, some of these checks are triggered only when files are uploaded to $PRODUCT_NAME_WORKFLOW application using options "Preflight Only (no correction)" or "Preflight and fix the first page only". When print data is uploaded without activating normalization options, detected objects are automatically corrected wherever possible.

A Print Object overlaps a Technical Color

This determines whether Technical Colors are overprinted by a print object. According to the ISO standard, Technical Colors always have to be placed at the very top of a print file as overprinting colors. This allows dielines located in the background to be detected and processed as follows:

  • Technical Colors are automatically moved to the foreground in a print file.
  • When the option "Preflight only (no correction)" or "Preflight and fix the first page only" is selected during upload, automatic Fixups cannot be performed for the file or for the subsequent pages of a multipage file. As a result, the error persists. When a match is found, the error message A print object overlaps a Technical Color [14] is displayed in the Page Information [13].

Figure 7: Page Information tab with the check

Technical Colors in a Multicolor DeviceN Definition

This determines whether Technical Colors are present in a multicolor DeviceN definition. According to the ISO standard, Technical Colors always have to be placed at the very top of a print file as overprinting colors. Therefore, dielines that are part of a multicolor DeviceN definition must be extracted and brought to the foreground as separate objects. The detected situation is handled as follows:

  • Technical Colors are automatically extracted from a DeviceN construct.
  • When the option "Preflight only (no correction) or "Preflight and fix the first page only" is selected during upload, it is not possible to automatically perform Fixups for the file or for the subsequent pages of a Multipage file. As a result, an error persists. When a match is found, the error message Some Technical Spot Colors are used as part of a multicolor DeviceN definition [16] is displayed in the Page Information [15].

Figure 8: Page Information tab with the error message

Dieline created as “rect” or “circle”

This check determines whether dielines are defined as a geometric rectangle rect or a circle circle. Dielines must consist of individual, connected path segments so that they can be processed correctly by cutter devices. The detected situation is handled as follows:

  • Dielines are automatically converted into individual, connected path segments when rect or circle is used.
  • When the option "Preflight only (no correction)" or "Preflight and fix the first page only" is selected during upload, it is not possible to perform Fixups automatically for the file or for the subsequent pages of a multipage file. As a result, the error persists. When a match is found, the error message Dieline is defined by a rectangle instead of Path elements [18] is displayed in the Page Information [17].

Figure 9: Page Information dialog with the warning

MediaBox of the Page is not at the Origin (0/0)

This check determines whether the MediaBox is not located at the origin of the PDF file coordinate system. Generally speaking, this situation does not pose a critical problem in the printing industry. However, to ensure consistent and reliable processing of print data in $PRODUCT_NAME_WORKFLOW application, objects must be normalized within the coordinate system. Detected situation is handled as follows:

  • The origin of MediaBox is automatically corrected to 0/0.
  • When “Preflight only (no correction)” option or “Preflight and fix the first page only” is selected during upload, it is not possible to perform Fixups automatically for the file or for subsequent pages of a multipage file. As a result, an error persists. A corresponding error message is displayed in the Page Information tab.
Page contains a Rotation Factor

This check verifies whether a rotation factor is present in a print file. Generally speaking, this situation does not pose a critical problem in the printing industry. However, to ensure consistent and reliable processing of print data in $PRODUCT_NAME_WORKFLOW application, rotation factor must be normalized, i.e., applied. Detected situation is handled as follows:

  • Rotation factor is applied automatically.
  • When the option "Preflight only (no correction)" or "Preflight and fix the first page only" is selected during upload, it is not possible to perform Fixups automatically for the file or for the subsequent pages of a multipage file. As a result, an error persists. A corresponding error message is displayed in the Page Information tab.
Multipage Print Items have Differing Page Sizes or Orientations

This check determines whether print file contains pages that differ in size and orientation. The use of different page sizes and orientations in print files is intended only in rare, exceptional cases. Situation is handled as follows:

  • No automatic Fixup is performed.
  • A corresponding warning message is displayed in the Page Information tab.

1.2.3. General Check-in Improvements – Switch to QuickCheck

In version 2.0.0, the check-in process was switched from the previous full PDF check to a QuickCheck wherever possible. For a QuickCheck, the complexity of a PDF document is virtually irrelevant. Preflight Results are usually available within a few milliseconds, regardless of how many pages, objects, or spot colors Print Item contains. The new checks described in previous section – which are performed when uploading print data – particularly benefit from this change, as they are now completed significantly faster.

1.3. Color Management

In version 1.22.2, a new feature in the color management section – Profiling Projects – was introduced. This section is available in Color > Profiling Projects. Profiling Projects are based on the GMG Color Engine and enable complete creation and management of Color Policies – from Pre-Linearization to Linearization and creating a Total Area Coverage Limiting to creating Characterization. In version 1.22.2, this feature was available exclusively to beta customers with activated beta access.

With version 2.0.0, Profiling Projects are now available to all new customers. Existing customers can switch from the ColorLogic solution to the GMG implementation. Depending on whether the license includes only GMG authorization or also includes ColorLogic authorization, certain menu items will be hidden in user interface. These includes:

  • Color Books
  • Color Correction –Based on Image
  • Color Management Settings –ColorLogic in System Settings
  • Color Setup
  • Profiling Templates

With version 2.0.0, following steps can be performed in a Profiling Project. The user has to stick to the order of steps:

  • Pre-Linearization (optional) – Enables manual adjustment of a printer's linear state per individual color channel.
  • Linearization – Enables the measurement of a linear state, including the limitation of the individual channels of a printing system, as well as definition of the transitions between light and dark inks present in a printing system. Whether this step is necessary depends on a printing system. When printing system has inline calibration, this step can be omitted.
  • G7 Linearization (optional) – Enables the measurement of the gray balance in accordance with G7 standard.
  • Total Area Coverage Limit – Enables the configuration and printing of a user-defined chart for the Total Area Coverage Limit, as well as creation of total ink density profile.
  • Characterization – Enables creation of Characterization profiles for printing system and a defined reference substrate. Based on this, ink-saving profiles are calculated and automatically made available in three definitions.

Note on License Scope

Which menu items are visible in your installation depends on the permissions that have been enabled. If you have any questions about switching from the ColorLogic implementation to the GMG implementation, please contact your sales partner.

Description of individual functions is available in user manual under Setting Up and Managing Profiling Projects. The following description explains the differences from an existing implementation in version 1.22.2.

1.3.1. Assigning Additional Substrates

User can assign additional substrates or all substrates to a Profiling Project. This feature eliminates the need to create a separate Profiling Project for each substrate when the same Color Policy can be used for multiple substrates with similar colors.

To assign additional substrates to a Profiling Project, proceed as follows:

  1. Navigate to Color > Profiling Projects.
  2. Select the desired Profiling Project from the list and open it.
  3. In the Overview [19] tab, in Additional Substrates section, click Edit [22].
  4. In Edit Additional Substrates dialog, select multiple substrates from the drop-down list [21]. By enabling Assign to all Substrates option [20], this Profiling Project becomes available for every substrate in the application.
  5. Click Save to apply settings. Selected substrates are then displayed in Additional Substrates section.

Figure 10: Edit Additional Substrates dialog with additional substrates selected

Other Options

You can also simply select the desired Profiling Project under Color > Profiling Projects and click Edit. The same function is also available in Edit Profiling Project dialog that opens.

1.3.2. Profiling Project – Status

Each Profiling Project now displays one of the following three statuses, making it easy to see the progress at a glance. The status is displayed in the footer [23] of the respective project.

  • Created – No sub-steps of the Profiling Project have been executed yet.
  • In Progress – Some sub-steps have already been executed, but not all steps have been completed yet.
  • Ready for Production – All steps have been completed, and a Color Policy has been generated.

Figure 11: The list of Profiling Projects with status indicators

1.3.3. Resetting Sub-steps of a Profiling Project Step or an Entire Step

Starting with version 2.0.0, each single step in a Profiling Project – such as Linearization or Characterization – can be reset either completely or back to a previous sub-step without affecting an entire Profiling Project. This eliminates the need to recreate an entire project when a Profiling Project step contains an error.

To reset a Profiling Project step, proceed as follows:

  1. Open the desired Profiling Project and then the step you want to reset.
  2. Click Reset [25] icon.
  3. In dialog that opens, select one of the following options from the Reset to [24] drop-down menu:
    • Home – Deletes everything in this step. You can proceed to the "Print" step.
    • Print – Deletes created Profiles (if available) and Measurements (if available). You can proceed to "Measure" step.
    • Measured – Deletes only Profiles that have already been created. You can proceed to the "Create Profile" step.

Figure 12: Reset Step dialog for the Characterization step

1.3.4. Deleting a Profiling Project

It is no longer possible to delete a Profiling Project when the Color Policy created within the Profiling Project is currently used in a Production Job. This prevents ongoing Production Jobs from becoming invalid due to the accidental deletion of the underlying Color Policy.

Figure 13: Delete Profiling Project dialog that appears when attempting to delete a project that uses a Color Policy

1.3.5. Gamut Viewer

Starting with this version, the Gamut Viewer can also display the color gamut of a Profiling Project based on the GMG implementation. The existing Gamut Viewer for ColorLogic profiles remains available, allowing to visualize color management approaches side by side and to compare them.

1.3.6. Creating a Print Chart – Total Area Coverage Limit

You can now create custom Print Charts for the Total Area Coverage Limit with a freely definable maximum value, which helps prevent contamination of a printing system.

To create user-defined Total Area Coverage Limit, follow these steps:

  1. In a Profiling Project, open Total Area Coverage Limit step.
  2. In that step, click Print substep and enable Expert Mode [26].
  3. In current dialog, click on Add [27] next to the Measurement Template Chart dropdown.

Figure 14: Add Total Area Coverage Chart dialog, which allows you to add a Custom chart

  1. In the opened dialog, specify the values for the chart.
    • Initial Value – Total Area Coverage [30] – Specify the total area coverage value for the first column of color patches in the chart. You can enter values ranging from 150% to 190%.
    • Final Value – Total Area Coverage [31] – Set the Total Area Coverage value for the last column of color patches in the chart. You can enter values ranging from 300% to 400%.
    • Number of variations per Color Channel Combination [32] – Specify how many rows should be calculated between the primary colors. You can choose between 2 and 3.
    • Show Text [33] – Specify whether or not to display captions for the columns. Disabling this option is only recommended when there is no space available for the captions.
    • Gap Width [28] – Specify the gap width between the color patches. This prevents colors from bleeding at the edges of the color patches.
    • Margin [29] – Set an additional margin around the entire chart.

Figure 15: General tab, which contains the parameters for generating a Total Area Coverage Chart

  1. In Advanced tab, specify the Patch Width and Page Height as well as the Max Page Width and Max Page Height you want to use for the chart.
  2. Click Save to generate the chart. Generated chart can be used for other printing systems in the future.

1.3.7. Minor Changes to Creating and Measuring Measurement Template Charts

Two minor changes were made in version 2.0.0:

  • Measure – measurement of a Print Chart must begin with Page 1 and continue in ascending order. After all pages have been measured, user is given the option to delete a page and measure it again.
  • Comment on a Print Chart – When creating a Print Chart, an option to enter a Comment has been removed, as the content of such a Comment can vary dynamically depending on a specific use case. However, the option to enter a Comment is still available in each step (e.g., Linearization, Total Area Coverage Limit, Characterization, etc.) by clicking the Print tab within a Profiling Project.

Figure 16: Left: The Add Characterization Chart dialog under the Color > Print Charts menu item; Right: The Measure dialog

1.3.8. Visualizations for Measurements — Two new Visualization Types

Starting with this version, two new visualization options are available in the Analyze step.

Color Axis

The option to display the color axes for the Color Space is available in the Analyze tab of the Linearization and Characterization steps. Use this information to visually assess:

  • How the color axis of a process color changes along the color ray from 0% to 100%.
  • Where the maximum chroma value will be located.

Figure 17: Color Axis tab of Analyze dialog in the Linearization step

Spider View

The option to display the spider web view for a Color Space is available in the Analyze tab of the Characterization step. Use this information to visually assess:

  • How the color axis of a process color changes along the color ray from 0% to 100%.
  • In which areas ECG (Extended Color Gamut) colors expand the color gamut.
  • Which gamut is covered by the profile. Profile comparison will be available in future versions.

Figure 18: Spider View tab of Analyze dialog in Characterization step

1.3.9. Color Correction in the Production Job

Starting with version 2.0.0, color correction calculations in the Output Configuration tab of a Production Job are based on the GMG implementation when a GMG color strategy is selected. In all other cases, the previous ColorLogic-based implementation is used.

1.3.10. Designation for GMG Color Policies

Starting with this version, GMG and ColorLogic Color Policies are clearly separated from one another in the Output Configuration drop-down list [34]—a subheading separates the different color strategies from one another.

Figure 19: Edit Output Configuration dialog with the Color Policies

1.3.11. Verification

Starting with this version, verification can be performed using either a GMG Color Policy or a GMG ink-saving strategy, depending on the selected Color Policy.

1.3.12. Grid Charts

Starting with this version, depending on the selected Color Policy, a Grid Chart can be created using a GMG Color Policy or with GMG ink savings.

1.3.13. Save Ink Profiles

Starting with this version, the pre-calculated Save Ink Profiles Low, Medium, and Extreme are available based on the GMG implementation for all Color Policies that were created with GMG:

GMG Save Ink Algorithm

When using the Extreme setting in conjunction with GMG Color Policies, significantly better visual results can be achieved than with the ColorLogic implementation. The improvements include better depth rendering in dark areas, as well as more saturated Hues – all while maintaining very similar ink saving values.

1.3.14. Handling Spot Colors

In version 2.0.0 all necessary functions are provided to enable DeviceN values calculation of spot colors in connection with GMG implementation. This affects the following areas:

Optimized Calculation Times

DeviceN values calculation of spot colors has been optimized in two ways:

  • DeviceN values that have already been calculated are cached for Print Items.
  • The GMG implementation calculates DeviceN values for many spot colors very quickly, as GMG provides a bulk calculation feature for spot colors.
Simulation Values for ∆E Display

The calculation of simulation values for the ΔE display has been implemented for all Color Policies created with GMG, so deviations between the target color and the simulated color can be tracked directly in the user interface.

Display in Print Item View

Please note that the calculated ∆E values for individual spot colors are displayed in the user interface with a slight delay for all Color Policies created with GMG.

Harlequin Host Renderer (HHR) – Switch to DeviceN Values

Separation values passed to the HHR will be fully converted to pure DeviceN values, rather than being passed via spot color profiles as it was handled previously. This change affects both GMG and ColorLogic Color Policies and ensures faster and more robust processing by the renderer.

Fixed Color Values

Calculation of fixed color values based on predefined values for individual channels is available for all Color Policies created with GMG. This allows individual channels of a spot color to be set to a specific value, while remaining channels continue to be calculated by the Color Policy.

Spot Color Report

The Spot Color Report uses GMG implementation to calculate color values for all Color Policies created with GMG. In addition, report also now displays the name of the Profiling Project [35] used, which improves the traceability of the used Color Policy used.

Figure 20: Spot Color Report displaying the Profiling Project

Axis Labels in the "Linearization" Step

Axis labels have been provided for displaying curves in the Linearization step, making it possible to immediately identify curves input and output values without having to click on individual curve points.

The following axis captions have been provided:

  • "Tone Values" tab – The x-axis is captioned with Input %, and the y-axis with the SCTV (Spot Color Tint Value).
  • "Chroma" tab – The x-axis is captioned with Input %, and the y-axis with the Chroma value.
  • "Reference Color Space" tab – The x-axis is captioned with Input %, and the y-axis with the ΔE00 value relative to the reference color space.

Figure 21: Left:Tone Values tab in the Analyze dialog; Center: Chroma Values tab; Right: Reference Color Space tab

Spot Color Definition – Additional Information

Starting with version 2.0.0, Create Spot Color Definition dialog correctly provides an additional information required for GMG spot color calculations. This gives users all the necessary options to calculate a spot color for the selected Color Policy.

  • GMG Additional Information [36] The following two options are available:
    • Separation Method – Selection of calculation accuracy
    • Max. Color Channels – Limits calculation to the selected number of channels.
  • ColorLogic Additional Information [37] – Only Conversion Method option is available here.

Figure 22: Left: Create Spot Color Definition dialog with the GMG Color Policy selected; Right: Create Spot Color Definition dialog with ColorLogic Color Policy selected

1.3.15. Handling RGB Colors

In version 2.0.0, an RGB DeviceLink profile is created based on RGB intermediate color space selected for the Profiling Project. This allows all RGB data with advanced parameters to be converted directly to Output Color Space or to intermediate color space.

When Print Item contains multiple RGB sources, an additional step is automatically performed before rendering to ensure consistent handling of all sources. The process is as follows:

  • For DeviceRGB objects, RGB source color space specified in system settings is assigned.
  • For ICC-based RGB data, respective ICC Color Spaces are converted to RGB Source Color Space used in Profiling Project. As a result, all RGB color values in Source Color Space always have the input color values that match RGB DeviceLink.

1.3.16. Preview Images – Printer Software

Starting with this version, the printer software preview now provides a calculation of the compensation curves for all Color Policies created with GMG, which are used to generate the color images. This has improved the image quality of the preview, as color transitions can now be factored into the calculation.

1.3.17. "Linearization" Step – Ink Cut

In Linearization section, starting with this version, values for ink cuts are also saved in the database, ensuring that they can be correctly retrieved when the step is edited later. Ink cuts displayed on the curves always match the numerical values shown next to them.

1.3.18. Characterization Step – Changes

The following changes have been made in the current version:

  • The name of the Variation must be unique in a Profiling Project. Otherwise, an error message will be displayed during creation [38].
  • Black is no longer used in the calculation of the primary colors cyan, magenta, and yellow, resulting in pure primary color values.
  • For Paper White Compensation [39] option in Separation Parameters tab, a visualization has been provided to help user understand how gray axis can be specifically adjusted to the desired reference white.
  • Variations can be deleted selectively, depending on whether the underlying Color Policy is currently in use. When the variation's Color Policy is not in use, only the variation is deleted. When variations Color Policy is in use, both the Color Policy and the variation are deleted.

Figure 23: Left: General tab when creating a Variation; Right: Separation Parameters tab with Paper White Compensation option

1.3.19. G7 Linearization Step

Additional step for generating G7 Linearization was added.

To use this step, please note the following:

  • G7 Linearization option [41] must be enabled when Profiling Project is created – it is not possible to enable it after creating Profiling Project.
  • This step is displayed as an additional step following the regular Linearization [40] which must also be enabled in the settings. When linearization is disabled, G7 linearization is also hidden.
  • G7 linearization is applied exclusively to CMYK Process Colors; ECG colors are not affected.

Figure 24: Add Profiling Project dialog with Advanced tab and G7 Linearization

1.3.20. Exporting / Importing Profiling Projects

Profiling Projects menu, with Additional Functions sub-menu [42] provides the possibility to export an entire Profiling Project [44] and import the project [43] into another instance of the application. This makes it particularly easy to transfer proven Color Policies between multiple locations or from a test environment to a production environment.

Figure 25: Profiling Projects menu, which allows you to import or export a project

1.3.21. Simplified User Interface

In this version, Color Management section in user interface has been simplified.

Depending on whether you have GMG or ColorLogic permissions, various menu items like Color Books, Image-Based Color Correction, Color Settings, Color Setup, and Color Setup Templates – are hidden to display only the functions that are actually available.

In addition, as soon as a Profiling Project sub-step of is completed, the user can proceed directly to the next step without having to activate Expert Mode.

Figure 26: Steps of a Profiling Project

1.3.22. System Settings

In Administration > Settings > Color Management > General, the ColorLogic specific parameters under Color Management Settings – ColorLogic [45] have been moved to a separate, clearly defined section. This provides a clearer overview, as GMG and ColorLogic settings are no longer displayed together.

Figure 27: General tab of the Settings > Color Management menu item, showing newly created section

1.3.23. Synchronizing Process Colors with "Color Service"

Starting with this version, in Administration > Inks > Ink Setup, manually synchronize a created Process Color with the Color Service. This is necessary, for example, to make selected Process Colorssuch as White –available to the Color Service after they have been newly created or modified in the system.

To synchronize a Process Color, proceed as follows:

  1. Navigate to Administration Inks Ink Setup.
  2. Select desired Process Color [48].
  3. Under Additional Functions [46], click Sync to "Color Service" [47] function.
  4. Wait until synchronization is complete. Process Color will then be available in the Color Service.

Figure 28: Ink Setup tab with the new synchronization feature

1.4. Fixups and Fixup Chains

Following existing Fixup was revised. In addition, further Fixups were made as part of the revised handling of spot colors.

1.4.1. Fixup "Rename, Convert or Remove Spot Colors" – Target Spot Color Name

In 1.22.2 version, an option to select a reference profile for color space conversion was added to Rename, Convert, or Remove Spot Colors Fixup.

With version 2.0.0, Spot Color Name – Destination [50] drop-down menu has also been revised when Rename [49] option is selected. Starting with this version, it displays only system-wide defined spot color names as well as names from spot color libraries. Spot color names that are used only by other Print Items no longer appear in Print Item selection list. This restriction prevents users from accidentally selecting a spot color name that exists only in another Print Item but is not defined as a valid spot color name system-wide or library-wide.

Figure 29: Rename, Convert, or Remove Spot Colors Fixup

1.4.2. Fixups – Removal of Processing Steps

Due to the revised handling of spot colors and Processing Steps, the input fields for the Processing Steps Group and the Processing Steps Type have been removed for a total of 20 Fixups in this version, as these parameters are no longer required for those Fixups. This has made mentioned Fixup dialogs clearer and simpler without changing the technical functionality of respective Fixups.

The following Fixups are affected by the removal of the processing steps information:

  • Duplicate Spot Color Separation
  • Add a Dieline for defined Text
  • Add Bleed on Irregular Shape
  • Add Wind Slits
  • Create a Knockout Rectangle
  • Create a Spot Color Separation for objects using the selected Spot Color
  • Day and Night Output
  • Derive a Dieline from Spot Color
  • Fill PageBox with Spot Color
  • Replace Dieline for Regular Shape
  • Add a Dieline for Irregular Shapes
  • Add a Dieline from the Center
  • Add a Dieline to the ImageBox
  • Add a Second Dieline
  • Add Caption
  • Add Objects on Layer
  • Create Spot Color Separation depending on Total Ink Coverage
  • Create Spot Color Separation for Object Type
  • Create Spot Color Separation to Printed Objects
  • Create White Only Separation

1.5. Automation

With version 1.19.0, users with an appropriate license have been able to create Automation Jobs. This allows to define custom Production Configurations for the manufacture of print products and automate their processing. For version 2.0.0, additional new features were implemented and existing functions were enhanced.

1.5.1. Article Detail View – Creating an Automation Job

Starting with this version, an Automation Job can also be created directly in detail view of an Article via Additional Functions [51], without having to go through the List of Articles or Production Scheduler. This speeds up the processing of individual Articles in particular for which an Automation Job should be created on short notice.

Figure 30: Article's detail view, which offers Create Automation Job function.

1.5.2. Additional Functions in Production Configurations – Restructured Menu

Additional Functions [52] menu in Automation > Production Configurations has been restructured. It is now organized as follows:

  • Export Job Ticket (divider) – Exports a job ticket for selected Production Configuration, which is intended to serve as a basis for developers who wish to run this Production Configuration via the API.
  • Export Production Configuration –Exports an entire Production Configuration. Note that referenced Fixup Chains, Fixup Templates, output configurations, etc., are not included.
  • Import Production Configuration (divider) – Imports a Production Configuration previously exported from another system.
  • Display Options – Here you can configure the list view for the Automation Production Configurations menu item.

Figure 31: Additional Functions menu in Production Configurations

1.5.3. Deleting Production Configurations – Quick Access

In the list of Production Configurations, a trash bin icon [53] is now displayed in the footer of each production configuration. This allows deleting a single Production Configuration directly from the list without having to select it first.

Figure 32: The list of Production Configurations, with a trash bin icon for each Production Configuration

1.5.4. Bundle View – Replacing a Print Item

In Bundle View under Automation Jobs tab, starting with this version, you can replace Print Items for each individual Automation Job within a bundle. Replace File [54] button is now available for this purpose.

Replacing a Print Item is helpful, for example, when an updated print file for a Print Item that has already been submitted needs to be provided during ongoing bundle processing. This feature can also be used when, during file verification, it is determined that wrong file was used for production.

Figure 33: Bundle of Automation Jobs tab

Replacing a Print Item in an Automation Job

In Production Configurations, create at least one status check for the Print Item and set up notifications for alerting the user when automatic processing fails. These alerts will notify user that an error has occured and allow to either ignore or fix the error, or – in the simplest case – to replace Print Item with a correct one.

Since replaced Print Item goes through all steps of the production configuration, make sure that replaced file actually meets the quality requirements of the Automation Job.

1.5.5. Disabling "Export Imposition Report" Operation for "Bound Product"

Generating an Imposition Report for Bound Product impose mode is no longer possible in Production Configurations starting with this version. This change is related to the restriction to a single Print Item described in section 1.1.5. Since a standard imposition report no longer makes sense in this case, an error message [55] is displayed when you attempt to save Production Configuration.

Figure 34: Invalid Production Configuration with Bound Product mode and Export Imposition Report Operation

1.5.6. Batch Processing – Validation When Saving

Starting with this version, when editing a Production Configuration using Create Production Job Operation, full validation for invalid Output Configurations is performed upon saving. This ensures that configuration errors are detected as soon as data is saved, rather than only when order is actually processed.

1.5.7. Hotfolder Job Ticket for Variants of a Production Configuration

Hotfolder XML or JSON structure has been expanded to allow representation for the Variants of Production Configurations in configuration. This makes it possible to specify, which Variant of a Production Configuration should be used for processing via Hotfolder.

Job ticket JSON structure for Variant of a Production Configuration is built as follows:

Figure 35: JSON example for defining Variant of a Production Configuration

XML structure for Variant of a Production Configuration looks like this:

Figure 36: XML example for defining Variant of a Production Configuration

1.5.8. Variations of Production Configuration – Copying the GUID

In detail view of a Production Configuration, you can copy variation's GUID to the clipboard with a single click [56]. This feature is particularly useful when working with XML or JSON Hotfolders, since variant must be precisely referenced using its GUID.

Figure 37: Variations dialog with Copy GUID to Clipboard icon

1.5.9. Variations of Production Configuration – Improved Searchability

Creating and viewing Variations is now directly available in the footer of Production Configuration.

  • Add New Variation – Create a variation by clicking Add Variation [58] in the footer of a Production Configuration. You can also do this by clicking Show Details [59] and selecting Add from the menu.
  • Number of Variations – To help users immediately notice whether variations exist for the Production Configuration, the footer displays the number [57] of available variations. You can also click the number to open the detail view and see all variations there.

Figure 38: Production Configurations menu item with the new overview

1.6. API

The following extension was added to the API for version 2.0.0:

1.6.1. Automation Jobs with existing Print Items

You can now create Automation Jobs by entering the Print Item ID that already exists in the system. Referenced Print Item is duplicated and processed as part of the new Automation Job, so that original Print Item remains unchanged.

1.6.2. Enfocus Switch Enhancements

Starting with version 2.0.0, following additional features are available in the API of Switch App:

  • Retrieving all Check-in Templates – All Check-in Preflight and Fixup Templates stored in the system can be retrieved via the API.
  • Retrieving and using Variations of Production Configurations – Switch Flows can specifically use a particular Variation of a Production Configuration.
  • Specifying the Check-in mode – When uploading Articles, choose between the check-in modes Preflight and fix the first page only or Preflight only (no correction).

1.7. User Interface

Following features were enhanced or added to the user interface:

1.7.1. Output Configuration – Color Management Information

Output Configuration [60] tab of Production Job provides information on Color Management [61]. This allows you to determine whether Color Management is enabled and what Color Correction is being applied to the output.

Figure 39: Output Configuration dialog with added Color Management information field

1.7.2. Hotfolder Migration Hint

When Hotfolders from the old user interface are still present in version 2.0.0 or later, Migrate existing Hotfolders [62] hint will appear in the header of user interface. At the same time, a more prominent prompt – "Open in new User Interface", will appear in the old user interface to speed up migration.

Figure 40: Application header with migration note

Migration is performed automatically starting with version 2.2

Please note that, starting with version 2.3 of $PRODUCT_NAME_WORKFLOW application, Hotfolder files that still exist in the old user interface will be migrated automatically.

Therefore, take advantage of the opportunity to migrate the Hotfolder manually and verify that the migration is fully functional. Migrations should be possible without restrictions in the new implementation. However, you should still perform a check beforehand.

1.7.3. Restructuring – "Administration" Menu Item

Administration [63] menu items has been converted from a flat list to a grouped list. As a result, related settings are now grouped by topic and are easier to find, especially in installations with a large number of administration options.

Figure 41: Administration drop-down menu with new structure

1.7.4. Production Scheduler – Limitation on Filter Display

When more than five values are selected for a filter [64] in Production Scheduler, display in the list is limited starting with this version to ensure clarity even for extensively configured routines.

Figure 42: Production Scheduler with filters that are not fully displayed

1.7.5. Standardized Color Values for Color Spaces

Display of color values for all Color Spaces has been standardized system-wide in the following areas:

  • CMYK and grayscale – Displayed with two decimal places.
  • RGB – Displayed without decimal places.
  • Lab – Displayed with two decimal places.
  • DeviceN – Displayed with two decimal places.
  • Tint values for spot colors – Displayed without decimal places.

1.7.6. Profiling Projects – Persistent Expert Mode and Standard Mode

Once you switch to Expert Mode [65] under Profiling Projects > Profiling Projects, this mode remains active system-wide until user actively exits. The same applies for standard mode. This means it is no longer necessary to switch modes every time when loading a page.

Figure 43: Create Characterization Profile dialog with Expert Mode enabled

Standard and Expert Mode

Switching between standard and Expert Mode applies to the entire application, not just a single Profiling Project.

When you want to exclude a user from Expert Mode, starting with version 2.2, you can do so via the User Role by disabling the Expert Mode permission in Global Permissions.

1.7.7. Selected Records Remain Selected

When selecting multiple records in a list and then performing an action on them, the records remain selected after the process is complete. This allows you to apply multiple processes in series to the same selection without having to reselect the records each time.

1.7.8. Changing the Substrate Type – Value is Retained

When switching between Substrate Types Roll Media and Sheet/Plate, value entered for Height Length or Roll Length [66] is retained rather than being completely reset while switching. This eliminates the need to re-enter the same value repeatedly when comparing the two Substrate types and matches the behavior in the old user interface.

Figure 44: Substrate Definition dialog with Substrate Type

2. Improvements

This section describes improvements made to existing features in version 2.0.0.

2.1. Color Correction in Production Jobs – Expanded Capabilities

Capabilities for Color Correction in Production Jobs have been significantly expanded. Following new options are available:

  • Midtones – Use sliders to specifically adjust the 50% hue for each CMYK channel.
  • Contrast/Brightness – Use the sliders to adjust brightness and contrast. The underlying curves – which are adjusted to the same extent for all color channels – adapt automatically.
  • Gradation Curve – For each color channel, gradation curve can be freely edited by adding, moving, and deleting curve points.

To apply color correction to a Production Job, follow these steps:

  1. Open desired Production Job.
  2. Navigate to Output Configuration [67] tab and then to Color Correction [68] settings area.
  3. Activate Enable Color Correction [69] checkbox.
  4. Depending on the desired effect – Midtones, Contrast/Brightness, or Gradation Curve –select from Correction Options [70] drop-down menu.
  5. Adjust the values using provided sliders (for Contrast/Brightness) or edit the curve directly in curve editor (for Gradation Curve).
  6. Save channges you have made either by clicking Apply Changes to Production Job or by saving color correction as a Template.

Figure 45: Color Correction section in Output Configuration tab of a Production Job

2.2. Curve Charts – Unified Editor

In version 2.0.0, the curve editing process was standardized system-wide. The editor:

  • displays curves [71] on the left side, showing input (X-axis) and output (Y-axis).
  • provides a tooltip [72] describing to modify curves.
  • allows applying changes to all or selected colors in channel selection [73] drop-down menu.
  • allows setting an exact input and output values [74] as percentages using two input fields when a curve point is selected, so that curve points can also be set numerically with precision.
  • allows deleting a selected curve point [75].

Unified curve editor is available in the following areas:

  • Production Job > Output Configuration > Color Correction
  • Data Preparation > Fixup "CMYK Color Correction"
  • Data Preparation > Fixup "Change Tint Value for Spot Color"
  • Profiling Project > Pre-Linearization > Curves

Figure 46: Edit Color Correction Curves dialog when editing or saving a template in Output Configuration tab of a Production Job

2.3. Handling Spot Colors – Simplified Definitions

Parameters available when creating Spot Colors have been simplified depending on the color type:

  • Non Printing Color [76] – Only color mode [77] CMYK, LAB, or RGB can now be selected.
  • Technical Color [78] – In color mode [80], RGB, CMYK, or Lab can be selected. In addition, Processing Steps Group [79] and Type must be specified.
  • Hybrid Color [81] – Assignment of Processing Steps Group and Type has been removed, as these are not technically required for hybrid colors. In color mode [82], RGB, CMYK, or Lab can be selected.

Figure 47: Left: Create Spot Color Definition dialog with Non Printing Color option; Center: Technical Colors option; Right: Hybrid Colors option

2.4. Enfocus Switch App – Enhanced Features

Starting from version 2.0, variations of Production Configurations can be queried and applied in Enfocus Switch App. In addition, specify desired Check-in mode Preflight and fix the first page only or Preflight only (no correction) directly when uploading.

2.5. Device Connector – Improvements

The following improvements were implemented for connecting printing systems via the Device Connector:

  • Drop size transfer – Drop size is transferred to the printing system, which requires this value for processing.
  • Automatic deletion of transferred print jobs – Print jobs are automatically deleted as soon as they have been transferred by the Device Connector and printed.
  • Transferring the media – Media width is transferred with the job ticket and is now derived from the Substrate Definition.
  • Renaming of the job ticket type – Job ticket type has been renamed from ERGOSOFT to Device Connector to align the name with its actual purpose.

2.6. XML Hotfolder – User-Defined Fields

XML specification for XML Hotfolder has been expanded so, user-defined fields can be passed directly using the XML structure. This allows to include user-defined information about a Print Item when transferring Print Item via an XML Hotfolder, without having to enter it later in the user interface.

Figure 48: Sample file for implementing user-defined fields in the XML structure

3. Small Improvements

This version includes several additional improvements:

3.1. Grid Chart – Placeholder for Color Names

To create Name for Grid Chart templates, a placeholder for Spot Color Name is provided from this version on.

To use this placeholder, follow these steps:

  1. Navigate to Color > Grid Charts.
  2. Click Add [83].
  3. In Add Grid Chart dialog that opens, click Save [84] next to the template selection field.
  4. In Edit Grid Chart Template dialog that opens, click Add Placeholder [85].
  5. Using the search bar, you can now select the Spot Color Name placeholder [86] located in Source Spot Color Name category.

Figure 49: Left: Add Grid Chart dialog; Center: Edit Grid Chart Template dialog; Right: Select Placeholder dialog

3.2. Login Dialog – Display of License Errors

Login dialog displays now an error message when the license being used is invalid. This provides users with clear feedback as soon as they attempt to log in, rather than having them encounter a license issue only after logging in.

3.3. Print Item Editor – Use Output Intent for Preview

When rendering the high-resolution preview in the Print Item Editor, the output intent defined in a PDF/X file is now taken into account, ensuring color-accurate color rendering.

3.4. Uploading Large Files – Sporadic Error

Calculating the preview in Quick Print and Batch Processing for very large files was likely to cause a crash. As a solution, the cache size was increased to 1 GB, and an application parameter was implemented to prevent the preview from being generated during upload, thereby speeding up the upload operation.

Starting with the next version, the preview feature in Quick Print and Batch Processing can be disabled system-wide. While this may be slightly less convenient for the user, it enables more stable and faster processing.

3.5. Routines – Exclude Deactivated Operations

When running routines via Execute immediately [88] in Administration > Routines, the number of affected records displayed is not calculated for deactivated Operations and is shown in the dialog as Deactivated [87].

Figure 50: Execute Routine dialog with an Operation disabled

3.6. Deleting Referenced Print Items

When only referenced Print Items are selected in the list of Articles/Print Items, Delete button in the dialog is disabled [89].

Figure 51: Articles with references when attempting to delete them

3.7. Article and Print Item List – Sorting by Substrate

The list of Print Items and Articles can now also be sorted by Substrate Name [90], allowing you to view Print Items and Articles specifically by substrate.

Figure 52: Print Items menu with the new sorting option by Substrate Name

3.8. Deleting the Default Color Policy

Deleting a Color Policy that is defined as system-wide default Color Policy [91] under Administration > Color Management > General > Color Options is now prevented. This ensures that Production Jobs are not left without a valid default Color Policy because Color Policy was accidentally deleted.

Figure 53: Color Options settings section in Administration > Settings > Color Management > General with the Default Color Policy selected

3.9. Printers – Deleting a Print Head

Starting from this version, a Print Head can only be deleted when no Color Configuration has been set up for the printer in question that requires that print head. When attempting to delete a required print head anyway, a corresponding error message [92] will be displayed.

Figure 54: Edit Print Heads dialog with the error message

3.10. Number of Print Items in a Collection

The number of Print Items displayed in a Collection can now be set to any value. Previous limitations of the display bubble [93] for very large collections have been removed.

Figure 55: Collection containing several Articles

3.11. Inks – Updated List

In version 2.0.0, the list of current ink information was updated in master data based on versions 04/2026 and 05/2026.

Previous Article Release – 1.20.0 (Major Release)
Next Article Release – 1.22.2 (Description)